Share to ios album discolor the photo

Bugreports = Bugfixes

Share to ios album discolor the photo

Postby MartinWong » Thu Aug 22, 2019 6:59 pm

In the latest version, when I long press on the photo and use share and then save to album, the photo is desaturated
MartinWong
 
Posts: 32
Joined: Wed Jun 03, 2015 10:36 am

Re: Share to ios album discolor the photo

Postby MartinWong » Thu Aug 22, 2019 7:02 pm

Here's a video showing the two methods producing different results
Attachments

2172272A-0409-477E-8531-816CC8E794DF.mp4 [ 12.97 MiB | Viewed 836 times ]

MartinWong
 
Posts: 32
Joined: Wed Jun 03, 2015 10:36 am

Re: Share to ios album discolor the photo

Postby TheBrew » Thu Aug 22, 2019 7:05 pm

Hm. Interesting. Could you attach a sample photo I can test this with?

Follow-up question:

You show two ways of saving the photo to the camera roll. One changes the colors and the other doesn't.

I assume (from what you describe) that it's the tap-and-hold the filmstrip, then save to Photos, that is the one where it goes wrong?

The difference between the two ways is: Using the share-sheet (tap+hold filmstrip) I just hand over the file to the iOS share sheet and everything from then on is totally in the hands of iOS.

The other way you show, where ShutterSnitch briefly displays an export-window, I use iOS's built-in save-to-camera-roll functions - and that one seems to work fine. (Unless the sorting is flipped around when you go into the Photos app?)

So the problem is - the issue seems to be with the iOS share sheet not honoring ..the color-profile embedded in the photo perhaps?
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4354
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Share to ios album discolor the photo

Postby MartinWong » Fri Sep 20, 2019 3:58 am

I can guess what happened. (Cause this happens to andriod version of instagram as well).
I shoot in Adobe RGB instead of sRGB, so it is an issue of some software. If you can fix that, that would be great.
MartinWong
 
Posts: 32
Joined: Wed Jun 03, 2015 10:36 am


Return to Bugs

Who is online

Users browsing this forum: No registered users and 1 guest