Page 2 of 3

Re: No backup

PostPosted: Wed Aug 01, 2012 1:02 pm
by evanpike
And yes, I tried quitting and opening again, but when I do open it, nothing happens (no icon in top bar nor does the window even pop up -- again this is on macbook pro, imac I can see the top bar icon).

I will check the password, but thought it was correct...

Re: No backup

PostPosted: Wed Aug 01, 2012 1:13 pm
by TheBrew
Is your ShutterSnitch username "evanpike.com"?

Try changing it to something without a dot in the name. (In the settings of ShutterSnitch, and also by double clicking the device in ShutterSnitch Backup)

Re: No backup

PostPosted: Wed Aug 01, 2012 1:20 pm
by evanpike
i think it is my email address... sorry, how can I change my username?

Re: No backup

PostPosted: Wed Aug 01, 2012 1:24 pm
by TheBrew
That would make sense. I better make sure that can work. ..it won't currently.

Open ShutterSnitch, go to the collection overview and tap the Options button in the top left-hand corner, then pick Settings.

The username should be right at the top.

And you change the username in ShutterSnitch Backup by double-clicking the device.

Re: No backup

PostPosted: Wed Aug 01, 2012 1:30 pm
by evanpike
Okay, changed it and it seems to be working on my desktop, no luck macbook pro, still says paused and no icon showing in top bar, but as long as it works with my iMac, I'm golden! Let me know if you want me to send more infomration about macbook pro if you are curious (or maybe it is just because it can't be backing up to 2 at once--but that doesn't explain the no icon in the top bar)?

Re: No backup

PostPosted: Wed Aug 01, 2012 1:39 pm
by TheBrew
Good to hear! Oh yeah - and remember, if you're using a WT or WFT to transfer photos from your camera to ShutterSnitch you'll also have to update the username there.
If you're using an Eye-Fi card, you don't have to do anything.

You can have 10 computers with SSB backing up at the same time if you wish :)

It sounds very strange that the icon doesn't show up - do you have many icons in the status bar? If there are too many, Mac OS will hide the ones on the far left.
Double clicking the device and picking your backup setting, username, and password doesn't change anything? (Did you try restarting the computer?)

Re: No backup

PostPosted: Wed Aug 01, 2012 2:27 pm
by TheBrew
Looks like there are issues with clean installs on Mountain Lion. Probably the new security settings.

I'm looking into it, and will return when I know more!

Re: No backup

PostPosted: Wed Aug 01, 2012 8:15 pm
by evanpike
Sounds good. I tried restarting already, no luck. Username and password look good. Not sure if it matters, but if I look at by top bar, the icon to the very left is dropbox and there is nothing next to it... BUT... if I click next to it anyway, the shuttersnitch icon shows up highlighted. As soon as I click somewhere else though, it disappears. Prob doesn't help you, but thought I would mention it just in case.

Re: No backup

PostPosted: Thu Aug 02, 2012 11:05 am
by TheBrew
OK, update: There's currently a known issue with Developer ID signed apps on Mountain Lion. Apple is investigating..

In case this is the reason for your ML issues, let's dig deeper when they have a fix (or if I find a workaround in the meantime).

I'll be back!

Re: No backup

PostPosted: Fri Aug 03, 2012 3:14 pm
by TheBrew
Solved!

It turns out that the signing issue is with Mountain Lion on the computer that signs the app for distribution. Downgrading to Lion and signing was the solution.

From now on, you should also be able to get things going on Mountain Lion. Either by installing the latest version or, if SSB is already installed, click the (invisible) icon in the status bar and pick "Check for application updates".

Thanks for pointing this issue out!