Page 1 of 3

Re: Bugs

PostPosted: Mon Jan 30, 2012 5:32 pm
by clive_architect
Hi, I was already able to backup a few times before without any hitch.

Now, when I try to backup, nothing happens. I typed the right password, chose backup everything from the slider, tried clicking the backup everything again checkbox, yet nothing happens. The only thing I did recently was update the ipad app to the latest version (v2.2.0). It just says in the window "Last Backup: Never". I have an Ipad 2 IOS 4.3.3. I need to backup all my photos before I update to IOS 5. Also, Im going on a vacation this weekend, memory on my ipad is almost full i need to clear up space for more photos. Please help, thanks

Re: Bugs

PostPosted: Mon Jan 30, 2012 7:14 pm
by MadDawgJ
Clive,
Check out viewtopic.php?f=12&t=414 for other ways to get your files off the iPad in case you run out of time troubleshooting.

When you were trying to back up the iPad was on, awake, on the same network and inside ShutterSnitch correct? Is this the same computer and network you have used to back up before?

Re: Bugs

PostPosted: Mon Jan 30, 2012 10:32 pm
by TheBrew
What MadDawgJ said - and if you have the time, try installing this newer version of ShutterSnitch Backup and let us know if it helped!

(And just to be sure it's not a screwy system, try restarting the iPad before doing the backup)

Re: No backup

PostPosted: Thu Jun 21, 2012 1:01 pm
by evanpike
I am also having issues with not all the files being backed up and trying to force it to "back up everything" doesn't work either.

Re: No backup

PostPosted: Thu Jun 21, 2012 2:03 pm
by TheBrew
Try installing this new version 1.1.2 - still problems?

1. Quit the currently running version of ShutterSnitch Backup.
2. Unzip (if it's not done for you) and drag it into your Applications folder, overwriting the old version.
3. Run it.

Re: No backup

PostPosted: Mon Jul 30, 2012 1:38 pm
by evanpike
I am now using 1.2.2 and still having no luck getting it to back up nor forcing a backup everything. Any thoughts? This was one of my favorite parts about ShutterSnitch, hope to get it working again!

Re: No backup

PostPosted: Mon Jul 30, 2012 4:02 pm
by TheBrew
Evan, I can't make it fail here with the latest ShutterSnitch (you're running the latest version, right? 2.5.0 at the moment - you can check this from the collection overview -> Options -> About and it'll be in the title).

Also, what iOS version are you running? (Settings app -> General -> About)

Perhaps you can get some pointers about what makes it fail on your setup, if you enable the logging feature in SSB:

* Click the magnifying glass in the top right-hand corner of your Mac screen and type "terminal", click the top result.
* In the Terminal window that opens, type defaults write com.2ndnature.ShutterSnitch-Backup debuginfo YES and press return.

Now, if you open the Console (magnifying glass -> type "console" and click the first result). You'll see some debugging output from ShutterSnitch Backup whenever it does something.

Let me know what you find out. I'm also interested in knowing if it only fails when / if you exit ShutterSnitch, or turn off the screen?

Re: No backup

PostPosted: Wed Aug 01, 2012 12:12 pm
by evanpike
Thank you for the reply. Yes, I am using the most recent version, 2.5, running iOS 5.1.1. I tried to do the terminal/console stuff, but there were already many lines in console, so I wasn't sure which one is the one you need. Can you please tell me what text to look for?

It doesn't matter if I exit SS, leave it open or turn off the screen, I can't get the backup to recognize any changes at all or force it back up everything again.

I also, I tried to install SS Backup on my macbook pro (it's running the new 10.8 but desktop is 10.7) and I can't get it to backup there either. On the macbook pro it says backups are paused and there isn't an icon in the top bar for some reason. Sorry for the trouble, but I appreciate you tying to help me find a solution.

Re: No backup

PostPosted: Wed Aug 01, 2012 12:20 pm
by TheBrew
Hi Evan,

There's a timestamp to the left in the console list. Try right clicking (or control-click, if you don't have a second button) your device in ShutterSnitch backup and pick "Backup everything again" - then see what it outputs in the console from the time you chose to backup everything again.

If there's a triangle to the left of the line in the console, you can click that and see more info.

Regarding the lack of icon in the status bar - have you tried quitting ShutterSnitch Backup (Cmd+Q while it's active) and re-launching it?

It can be paused, if the password is wrong - if you double-click the device, you'll be able to re-enter it.

Re: No backup

PostPosted: Wed Aug 01, 2012 1:00 pm
by evanpike
Okay here is what I copied from Console, hope this helps:


8/1/12 7:57:49.330 AM ShutterSnitch Backup: Backup started for device 'iPad'
8/1/12 7:57:49.337 AM ShutterSnitch Backup: progress: 1343819471.270549
8/1/12 7:57:49.337 AM ShutterSnitch Backup: target: evanpike.com:a5475967b7b9bfb1245a703f8794fc77@iPad-6.local.:46787/modifiedsince/1343819471.270549
8/1/12 7:57:49.549 AM ShutterSnitch Backup: Reply: (
"",
"",
........
"</html>",
""
)