Partially Gray Images upon transfer

Help and ask for help on Toshiba FlashAir card related problems

Partially Gray Images upon transfer

Postby papasula » Mon Mar 04, 2013 8:06 pm

I am using the FlashAir card in an Olympus E-PL5 going to an iPad Mini running 6.1.2 and every 4th or 5th image only partially renders with the remaining part of the image coming up as gray. I am connecting using the Private Connection or the Onetime Connection modes and have the issue in both. I have set the timeout threshold to 5 minutes for both the camera and the iPad.

Help!!! I love this app but this issue is driving me crazy!

Thanks in advance!
papasula
 
Posts: 7
Joined: Mon Mar 04, 2013 7:33 pm


Re: Partially Gray Images upon transfer

Postby TheBrew » Mon Mar 04, 2013 8:35 pm

If you stay in the collection and change to the Safari app and type this into the address bar: http://localhost:8080
it should ask you for a username and password. Type in snitch and your ShutterSnitch super user password. Then you should see the list of files inside the current collection. Then find the photo that was partially gray and tap that - is it also partially gray in Safari?
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4463
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Partially Gray Images upon transfer

Postby papasula » Mon Mar 04, 2013 9:00 pm

I will try that once I'm off work later today...thanks for the quick support.
papasula
 
Posts: 7
Joined: Mon Mar 04, 2013 7:33 pm

Re: Partially Gray Images upon transfer

Postby papasula » Mon Mar 04, 2013 11:16 pm

It is the same in the Safari browser...partially gray.
papasula
 
Posts: 7
Joined: Mon Mar 04, 2013 7:33 pm

Re: Partially Gray Images upon transfer

Postby TheBrew » Mon Mar 04, 2013 11:28 pm

OK. I'm guessing it could be one of two things: it could either be a timeout during the transfer that doesn't end up in a failure but just reports as a complete download or maybe it happens because the photo is only partially written to the card and ShutterSnitch is too fast at initiating the transfer.
What is your experience? Does it only happen when you take many pictures in rapid succession or has it happened after you know all photos are completely saved to the card?
Does it happen as a result of a timeout? Are the files very big?
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4463
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Partially Gray Images upon transfer

Postby papasula » Mon Mar 04, 2013 11:40 pm

I haven't even tried any rapid succession photos. All have been after the camera stops flashing the "write" icon. I have set both them era and ipad to time out after 5 minutes but these are all taken well before that time (thus resetting time out period. I started with shooting raw + jpeg then, thinking the files were too big, shot only jpegs at the smallest size.
papasula
 
Posts: 7
Joined: Mon Mar 04, 2013 7:33 pm

Re: Partially Gray Images upon transfer

Postby TheBrew » Mon Mar 04, 2013 11:47 pm

From what you say, it sounds like the transfers just fail mid-transfer, but are reported as done.

I've just added some code that'll check the incoming file when the download is done. If it's an incomplete JPEG file it'll ignore it and re-download it in the next go. This will be live in version 2.9.4 (2.9.3 is currently in review at Apple).

Then you shouldn't see any of this again.

A side note: if you'd like to have RAWs saved to the card, but not transferred, you can go into the ShutterSnitch settings and turn on "Accept JPEGs only".

If you see a pattern as to how these partial transfers occur, please let me know.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4463
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Partially Gray Images upon transfer

Postby papasula » Tue Mar 05, 2013 12:22 am

I have the "jpegs only" option checked. Thanks so much for support and communication!
papasula
 
Posts: 7
Joined: Mon Mar 04, 2013 7:33 pm

Re: Partially Gray Images upon transfer

Postby TheBrew » Tue Mar 05, 2013 12:29 am

You're very welcome. Thank you for bringing this issue up. If you're still having problems with version 2.9.4 please let me know so we can dig deeper!
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4463
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Next

Return to Toshiba FlashAir cards

Who is online

Users browsing this forum: No registered users and 1 guest

cron