Page 1 of 1

Station Mode not working with Shuttersnitch

PostPosted: Tue Oct 28, 2014 12:49 pm
by floyd
Hey there,

I'm in progress to move my setup over to the 2nd generation of Toshiba Flash Air Cards coming from EyeFi X2 Pro. When I configure the Toshiba Flash Air Card in Access Point Mode, everything works as normal. I can access the card from my iPad via Safari at http://flashair, http://IPADRESS and http://flashair.local and for sure I can Shuttersnitch confirms a connection and transfers the pictures.

If I follow this https://flashair-developers.com/en/documents/tutorials/advanced/1/ tutorial instead the Flash Air Cards connects with my Router; but I can just access it via Safari at http://IPADDRESS and http://flashair.local. ShutterSnitch doesn't find my FlashAir Card at all.
I use of course "flashair" as APPNAME instead of "myflashair" as in the tutorial and it doesn't matter which value I enter at DNSMODE.

Since I'm skeptic that Toshiba will change anything I would love to know how ShutterSnitch looks for the FlashAir card in the network? Just by accessing http://flashair? Would it be possible to somehow state an IP address instead of the name? Or just to change the flashair to flashair.local?

Thanks
Malte

Re: Station Mode not working with Shuttersnitch

PostPosted: Tue Oct 28, 2014 1:58 pm
by TheBrew
Hi Malte - fear not, Station Mode will work in the next version!

It's just that Apple is currently ages about approving updates, so it could be 2-4 weeks.. :/ Hang in there.

Re: Station Mode not working with Shuttersnitch

PostPosted: Wed Oct 29, 2014 10:03 pm
by floyd
Thanks for the answer!

Re: Station Mode not working with Shuttersnitch

PostPosted: Tue Oct 06, 2015 8:48 pm
by mitchell.hobizal
Well this post is about a year old, but I am having the same issue... I set my FlashAir card up in station mode to connect with my D-Link DIR-655 Router, then turn on my phone's wifi, connect to the router, open shuttersnitch, and there is no link to my FlashAir card. I can access it by typing in its allocated IP, but by no other means...

I have tried renaming the card, but no luck. I have also tried entering the ip of the card given to it by the router into the host column of the p2p/eos section of Shuttersnitch, but only the router shows up to "import" from. Which Shuttersnitch FW update was this supposed to be fixed in? Any suggestions

Re: Station Mode not working with Shuttersnitch

PostPosted: Tue Oct 06, 2015 9:12 pm
by TheBrew
Version 3.2.2 fixed the issue back then.

But Toshiba can at any point send out an updated firmware that changes how things work. Software is ever-changing (and Toshiba FlashAir more than any other cards it turns out.).

Only the "Toshiba FlashAir" switch in the ShutterSnitch settings will affect the connection to your card.

* What IP does the card get when it joins the network?

* Do you get to the card if you type in http://flashair or http://flashair.local in Safari on your device?

* Please go into the ShutterSnitch settings, scroll all the way to the bottom and turn on "Traffic Inspector". Then enter a collection and see what the log says when it tries to find the card. After you've given it some time to fail, please copy the log and paste it in a post here.