Page 1 of 1

Problemantic behavior

PostPosted: Sat Aug 26, 2017 3:15 pm
by msatter
I have noticed that the FlashAir is a bit more demanding in usage than the previous cards I used.

I create an collection in SN and go into it. Now the AirFlash is connecting and the listeninfo is displaying FlashAir 2 or FlashAir 1 and when I receive pictures I see that pictures are received with the and "-1" added to their name. I can't see in the SN directory any more to see if the extra files are also saved.

SN ignores these extra pictures with the added "-1" to their name. To fix this double registration of the FlashAir it is correctable by go back to the collections and enter the collection again.

So my suggestion is to automatic leave the display screen and return to the collection and enter again the collection. This will give a clean connection to the FlashAir that is registered in the WiFi network on the iPad.

This can probably done also in the background so that user does not see that.

I was testing this and wanted to test the auto power of by the camera and because I use the Eye-Fi setting (available in the w-04 version of the card) the camera did not go in powersave. So I disabled the Eye-Fi setting and after an minute the camera went to sleep and I woke it up and enabled the Eye-Fi again. The connection came back but SN did not noticed that and is still displaying as listening info: "Connected to Toshiba FlashAir" and it is not accepting pictures taken by the camera.

My default response is than, to go back to collection and enter the album again and on entering it displays connecting to the FlashAir and instantly transmitted the pictures.

Does IOS notify when a new WiFi connection is established or a reconnect so that you can use tht trigger it to scan for available cards?

Not only the FlashAir but also my Transcend had "-1" files in the directory so it was also happening in earlier versions of SN.

Checked the files on my SD card and there are no double files on there.

Now it is really becoming strange. I switch off the camera and I see that WiFi connection times out and then SN displays that is connects to FlashAir....there is no WiFi connection at all so how does SN do that. My default solution does clear this and displays : "No network connection" which is confirming the real status.

Re: Problemantic behavior

PostPosted: Sat Aug 26, 2017 3:40 pm
by msatter
Test one:

WiFi connection active and start SN. Enter collection and traffic inspector checks for new files. Switch of camera and after disconnect traffic inspector displays "Disconnected from flashair.local" and ends with "No reply from FlashAir card". Listening info displays that it is still connected to the FlashAir.
Switching on the camera and the WiFi is connecting......takes a while....connected but the traffic inspector is not adding any lines and I have to do my default solution to bring SN to life.

Now traffic inspector is coming to life and displays an error in feed: failed to bind on to SSDP port. (Error Domain-NSPOSIErrorDomain Code=48 "Address already in use" Userinfo={NSLocalizedDescription=Address already in use, NSLocalizedFailureReason=Error in bind()function})

When switching off and having now my FlashAir and Transcend enabled and Ey-Fi disabled in the menu I get in traffic inspector that the broadcast to lo0 = "" has failed.

Having only a FlashAir Card selected in the "Setup Guide" screen gives an problem as the Eye-Fi is also activated at the same time by default. Switching of the Eye-Fi support solved my problem with reconnecting to the FlashAir.

Re: Problemantic behavior

PostPosted: Sat Aug 26, 2017 3:50 pm
by TheBrew
Thanks. I have found the bug. Will be fixed in the next version.

Re: Problemantic behavior

PostPosted: Sat Aug 26, 2017 4:01 pm
by msatter
I have added more debug stuff later in the posting above.

First, the reconnect conflicts in some way with the Eye-Fi setting.

Two, double import on reconnect but they seemed to be ignored by SN.

Re: Problemantic behavior

PostPosted: Sat Aug 26, 2017 4:08 pm
by msatter
Three and new. I have only FlashAir activated in the setup.

On reconnect the total downloaded list is increased and stated that a picture was added tot the download cue but no pictures are downloaded. My default solution makes SN to download the pictures that were on the download list.

If you need more info then I am more than happy to provide and if not I will wait for the next version of ShutterSnitch.

Re: Problemantic behavior

PostPosted: Tue Aug 29, 2017 9:30 pm
by msatter
I have just tried ShutterSnitch 3.7.17 and the background is now working and more important the FlashAir just works as intended with Eye-Fi support in SN enabled or disabled. Thanks for the swift fix of the bugs.

Do we need Eye-Fi support enabled in SN because these cards are getting rare and maybe you need it if you are using Keenai?

I had some problems starting the slideshow in SN because on the first time I had to scroll down the pull-down to discover the "Start Slideshow" line.

I tried to execute the shuttersnitch:// in Safari to have custom settings but those commands are not more accepted.

I was thinking of this because the iPad Pro has a different max screen resolutions then the 9.7 iPad. The 10.5 has a max screen resolution of 2224 and the 12.9 of 2732 and maybe it easier to communicate if you just add to the "Max. cache image dimension" besides the current options the current models of iPhone and iPad models and in the background you use the max. screen resolution for that family of iPhone/iPad.

Table of different resoltions:

Re: Problemantic behavior

PostPosted: Tue Sep 19, 2017 9:39 pm
by msatter
I did see the import update to version 4.0 and I am eager to try it out. I will have to wait till next week because I have an important shoot this week and I don't want run any risks because approving a new version takes a few days.

Thanks for you great work to bring the updates to Shuttersnitch and give your fingers some more needed rest. ;-)

I have now updated to 4.01, skipped 4.0, and did a short test and al seems to work as expected.

I have now updated to 4.02 and thank for addressing the problem with multiple connections to a Toshiba Flashcard

Re: Problemantic behavior

PostPosted: Thu Sep 28, 2017 1:17 am
by sjcarrera
On Sunday's Bears (Chicago American pro football team) game I would drop to ShutterSnitch and then to Dropbox as I have all season long but found that the files were going to the Dropbox folder for the volleyball game from the night before. I tried to renter the path the Bears folder but that didn't matter it continued to go to the volleyball game folder. After the game I deleted both the actions for volleyball and and Bears (which had separate actions) and after making new actions all is fine. What I would do is just change the path of the action not create a new action each time.