Support for Fujifilm X-T2

Help and ask for help on Fujifilm cameras with built-in Wi-Fi

Support for Fujifilm X-T2

Postby Bernward » Fri Jun 23, 2017 9:17 am

Hi,
my Setup: X-T2 with FW 2.10, iPad with ShutterSnitch V3.7.7, TP-LINK Router AC750

With V3.7.7 the build in wifi of my X-T2 works with ShutterSnitch: I open a collection, start wireless fixed at X-T2 menu, after a while LED at X-T2 begin to blink green, ShutterSnitch message "Connected to X-T2". I take a Picture, JPG receives in ShutterSnitch ... OK so far. but now the LED of my X-T2 is blinking green and red all the time! I can take a second Picture ... LED keeps blinking green and red.

My Problem: i can not end the session taking pictures!!! In the menu of the X-T2 the point to turn off "wireless fixed" is shown grayed! X-T2 is no more operable to turn off!! The only way to end the session is to first delete the collection in ShutterSnitch, then "OK" on X-T2, then turn off X-T2. Second way is to remove the akku of the X-T2.
Can anybody help?
Kind regards
Bernward
 
Posts: 9
Joined: Thu Jun 22, 2017 2:05 pm

Re: Support for Fujifilm X-T2

Postby TheBrew » Fri Jun 23, 2017 9:55 am

You don't have any other computers / devices joined to the TP-LINK router, correct?

And you don't have any of the Fujifilm apps running in the background / on any connected device? That'll probably cause chaos. :)

Have you been using / playing with the wi-fi transfer functions on the camera before ShutterSnitch added support for it?
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4426
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Support for Fujifilm X-T2

Postby Bernward » Fri Jun 23, 2017 10:27 am

#1 I have no other device joined to the pocket router for the X-T2 test.
I use the router to handle my EOS 6D with build in wifi, my X-T20 with Transcend WI-FI card and up to now my X-T2 also with Transcend card side by side - works fine so far.
I try to switch from Transcend card to intern wifi with my X_T2.

#2 I do not use any fuji app running in the background at same time. But i tested Fuji's HS-V5 and XAcquire separat. It works fine without problems to end the session. During JPG transfer the X-T2 LED is blinking amber, upon completion it is blinking green only again.

#3 Yes, i have been playing to run bild in wifi transfer since X-T2 FW 2.1 before ShutterSnitch 3.7.7. I have already done a reset in wifi menu and a new adjustmend of wifi on my X-T2 without success.
Last edited by Bernward on Fri Jun 23, 2017 1:36 pm, edited 3 times in total.
Bernward
 
Posts: 9
Joined: Thu Jun 22, 2017 2:05 pm

Re: Support for Fujifilm X-T2

Postby TheBrew » Fri Jun 23, 2017 10:48 am

You mention 6D. I wonder if the Fujifilm traffic is colliding with the other similar supported services. Could you try going into the ShutterSnitch settings and turn off the 'Enabled' button in the PTP/IP (NIKON WU / EOS UTILITY) section and try again?

If it still fails, try scrolling all the way to the bottom of the ShutterSnitch settings and turning on 'Traffic Inspector'. Then see if it logs anything interesting when it fails. Then please post the output here.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4426
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Support for Fujifilm X-T2

Postby Bernward » Fri Jun 23, 2017 11:26 am

after turning off PTP/IP it still Fails. My EOS 6D is not in use for the X-T2 test.
Traffic Inspector opens a window and is writing a lot. I can "copy" and "end" the inspector. I hit copy first then end. But i don't know to handle the log-file. iTunes show me files like fileinfo.sqlite-wal or Shoots.plist or a Folder Shoots. Where is the logfile and what is its Name?
Bernward
 
Posts: 9
Joined: Thu Jun 22, 2017 2:05 pm

Re: Support for Fujifilm X-T2

Postby TheBrew » Fri Jun 23, 2017 11:33 am

'Copy' copies the log to memory. You can then paste it in a post here.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4426
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Support for Fujifilm X-T2

Postby Bernward » Fri Jun 23, 2017 11:42 am

OK, but ShutterSnitch is running on my iPad connected to the wifi-router without Internet.
My post is on my PC with Internet connected to my home-router. I can connect my iPad to my PC via USB and then use iTunes running on PC. Don't know to copy and past from iPad to PC!
Bernward
 
Posts: 9
Joined: Thu Jun 22, 2017 2:05 pm

Re: Support for Fujifilm X-T2

Postby TheBrew » Fri Jun 23, 2017 12:14 pm

Can't you just disconnect from the TP-Link router, join your home-wi-fi and then use Safari to post the log? The copied log text will stay in memory until you copy something else up there.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4426
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Support for Fujifilm X-T2

Postby Bernward » Fri Jun 23, 2017 12:44 pm

Code: Select all
Device: iPad4,1, 64-bit, iOS 10.3.2 (Bernwards iPad)
Free memory: 424.394.752
Free disk space: 32.063.471.616
Time: 23.06.2017, 13:20:33

13:20:33.688 Listening…
13:20:33.700 ShutterSnitch version: 3.7.7 (12592)
IP: 192.168.8.101 on network 'B2WIFISD'
FTP port: 26000
WebDAV port: 8080
Eye-Fi: Disabled (0 cards)
PTP/IP: Disabled
Transcend Wi-Fi card transfers: Disabled
Toshiba FlashAir transfers: Disabled
ezShare transfers: Disabled
PQI Air / Air Direct transfers: Disabled
GoPro transfers: Disabled
Panasonic LUMIX LINK transfers: Disabled
Sony DLNA transfers: Disabled
Canon UPnP transfers: Disabled
Fujifilm transfers: Enabled
13:20:33.713 Started WebDAV server on port 8080
13:20:34.762 Fujifilm PTP/IP: Connecting to 192.168.8.105:15740
13:20:35.269 Fujifilm PTP/IP: Connected to X-T2@192.168.8.105 Device Properties: (null)
13:20:55.299 Fujifilm PTP/IP: Downloading info on objects...
13:20:55.370 Fujifilm PTP/IP: Got info for 2 objects
13:20:55.380 Fujifilm PTP/IP: Skipped downloading DSCF0001.raf. Settings say 'only download JPEGs'
13:20:55.390 Fujifilm PTP/IP: Saving 1 file
13:20:59.576 Fujifilm PTP/IP: Downloading info on objects...
13:20:59.630 Fujifilm PTP/IP: Failed to get ObjectInfo for photo no. 2 (Error Domain=Access denied Code=8207 "(null)")
13:20:59.641 Fujifilm PTP/IP: Got info for 0 objects
13:20:59.646 Fujifilm PTP/IP: No available files / We already have the ones on offer?
13:20:59.736 ShutterSnitch Feed notification sent
13:21:33.098 Started WebDAV server on port 8080
13:21:40.478 Started WebDAV server on port 8080
13:22:15.601 Fujifilm PTP/IP: Downloading info on objects...
13:22:15.648 Fujifilm PTP/IP: Failed to get ObjectInfo for photo no. 2 (Error Domain=Access denied Code=8207 "(null)")
13:22:15.700 Fujifilm PTP/IP: Got info for 2 objects
13:22:15.720 Fujifilm PTP/IP: Skipped downloading DSCF0003.raf. Settings say 'only download JPEGs'
13:22:15.733 Fujifilm PTP/IP: Saving 1 file
13:22:19.851 Fujifilm PTP/IP: Downloading info on objects...
13:22:19.877 Fujifilm PTP/IP: Failed to get ObjectInfo for photo no. 3 (Error Domain=Access denied Code=8207 "(null)")
13:22:19.886 Fujifilm PTP/IP: Got info for 1 object
13:22:19.896 Fujifilm PTP/IP: Skipped downloading DSCF0003.raf. Settings say 'only download JPEGs'
13:22:19.903 Fujifilm PTP/IP: No available files / We already have the ones on offer?
13:22:19.947 ShutterSnitch Feed notification sent
Bernward
 
Posts: 9
Joined: Thu Jun 22, 2017 2:05 pm

Re: Support for Fujifilm X-T2

Postby TheBrew » Fri Jun 23, 2017 1:05 pm

Ah! I see the problem..

Fujifilm's tethering mode works by receiving the file and then telling the camera to delete it from the card. When the camera receives the delete command, it moves on.

In your case, the ShutterSnitch settings is set to only receive JPEG files. So ShutterSnitch ignores the raw and never asks the camera to delete the file.. So the camera goes into confused-mode when SS asks for the next photo. So, I need to update my code to ask to delete the raw it just ignored.

Luckily the solution for you, doesn't rely on that update. You just have to make a choice:
1. If you want to receive the raw files, go into the ShutterSnitch settings and find the "Accept JPEGs only" and turn that off.
2. If you don't care abou raws, tell the camera not to save raws.

After doing that, does it work?
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4426
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Next

Return to Fujifilm Wi-Fi

Who is online

Users browsing this forum: No registered users and 1 guest