Push now works with X-Pro 2 (w firmware 4.00)

Help and ask for help on Fujifilm cameras with built-in Wi-Fi

Push now works with X-Pro 2 (w firmware 4.00)

Postby Ranger 9 » Sun Dec 24, 2017 3:59 am

I was SUPER pleased to discover the wireless tethering/push feature added in ShutterSnitch for the X-P2, and even MORE pleased to discover that it works with my X-Pro 2 since installing the firmware 4.00 update. This means I can retire the Eye-Fi card that was tying up the second card slot in my camera!

Setup is pretty much as noted in the setup guide, although some options have slightly different names (e.g. instead of being called "PC Shoot Mode" it's called "PC Connection Mode.")

I also was very pleased to discover that although the setup guide says files will be deleted from my camera memory card after being transferred, this does NOT seem to be the case with this camera/firmware combination. I was very relieved about this because I like to have my raw files saved to the card (because it's so slow to transfer them to the iPad) and just send the JPEG files to ShutterSnitch for viewing as I shoot. As best I can figure out, the USB tethering setting does allow the option of saving files to the camera card (although this option is off by default) and it seems to carry over to wireless tethering. At any rate, I really like being able to continue saving my raw files to the card and sending JPEGs to the iPad, so if this behavior is a bug, please do NOT fix it!

This is GREAT support and I really appreciate it! Thanks!!
Ranger 9
Posts: 34
Joined: Thu May 06, 2010 3:25 am

Re: Push now works with X-Pro 2 (w firmware 4.00)

Postby photogsbrashear » Tue Jan 16, 2018 2:07 am

Perhaps I'm doing something wrong, but I'm unable to get my cameras to save the RAW files on the card, even when I have have Shuttersnitch set to accept JPEGs only. First, I did update the FW to 4.01, but I cannot imagine that such a small incremental (bug fix) upgrade would change the wireless settings.

I connect to iPad through its hotspot, rather than over a (traditional) Wi-Fi network. Not sure this would be an ad-hoc network or not. The camera is assigned an IP by the iPad.

I'm also able to to connect to the camera via the iPad and browse photos and push photos, but not tether the camera.

Are there any settings or setup that I am missing to workaround the camera not saving images to the card while wirelessly tethered?
Posts: 1
Joined: Thu Feb 19, 2015 8:06 pm

Re: Push now works with X-Pro 2 (w firmware 4.00)

Postby Ranger 9 » Wed Jan 17, 2018 4:53 am

I know there's a setting in the Cellular Data pane for "Set Up Personal Hotspot," but I've never used it, so I'm not sure what to tell you.

What I can tell you is how I set up the X-Pro 2 to communicate through a regular WiFi router (I carry around a RavPower mobile router to create the connection.) Then you can compare my settings to yours and see if this gives you any hints.

First create a new collection in ShutterSnitch, since it won't make a connection available if you're not in a collection.

Next set up the camera: Make sure you have a card in a slot, so there's a place to save your raw files, and that your Image Quality settings are set up to same some form of JPEG + raw. (If you don't have a card in the slot, it will send JPEG files over WiFi anyway, but if there's a card, you have to be set to JPEG + raw.) Note that your JPEG files won't be saved to a card even if you set your data-storage settings to save JPEG to one card and raw to the other; I thought that worked, but it doesn't seem to be working now (possibly after 4.01 update?)

The settings you need to make for WiFi are all in the camera's Connection Setting menu (under the wrench icon):

-- Make sure "PC Connection Mode" is set to "USB Card Reader"; you won't be able to change some needed settings if it isn't.

-- Go up to "Wireless Settings" and choose "Access Point Settings." Here you set up access to your router (which in your case I assume would be your iPad, but as I said, I haven't tried this type of setup.) Presumably if you already are pulling an IP address from your access point, this setup is working, but since your setup isn't working correctly, you might as well check all these settings just to make sure.

-- Now go down to "PC Connection Mode" and set it to "Wireless Tether Shooting Fixed," push the OK button, and back out of the menus.

Once you've done this, the back LED should flash orange while the camera is looking for a connection. If it finds it, the LED will flash green. When there's data waiting to send, it will alternate green and red. If it loses the connection (which it will if you back out of your ShutterSnitch collection, for example) the LED will flash red while it's trying to re-establish the connection, then orange after it gives up. If you re-open your collection, it usually will reconnect and show flashing green.

Annoying thing 1: If it's flashing orange, you can't change your connection settings or even turn off the camera. The only way I've found to get out of this is to take out the battery.

Annoying thing 2: The numbering of JPEG files sent to the iPad doesn't sync up with the numbering of raw files saved on the card. This makes it impossible to use the otherwise super-useful Snitch Sync plug-in to synchronize ShutterSnitch star ratings, descriptions, etc. to a Lightroom catalog. Obviously if you don't use Lightroom this won't bother you, but it's really inconvenient for me. Update: I just realized I can fix this by defining a ShutterSnitch action that renames the files sequentially after they're received.

I'm guessing that you already have your camera set up as above and that the reason it isn't working for you is some peculiarity of using the iPad as a hotspot. Maybe you could try with a regular infrastructure-type WiFi network and see if it works there, just as a test...?
Ranger 9
Posts: 34
Joined: Thu May 06, 2010 3:25 am

Return to Fujifilm Wi-Fi

Who is online

Users browsing this forum: No registered users and 1 guest