Setting up your connection

Help and ask for help on your Canon wireless file transmitter

Re: Setting up your connection

Postby Ikyo » Mon Jun 14, 2010 10:33 pm

I keep getting an error 99 on it. It creates folders like 000001 with nothing in it. I will have to see what it does on my Mac.
Ikyo
 
Posts: 10
Joined: Thu May 13, 2010 10:38 pm

No luck connecting from wft-4IIA

Postby hermosawave » Wed Jun 30, 2010 6:28 am

Not getting any luck connecting my 5DMkII and WFT-4IIA to shutter snitch. I can connect to ShutterSnitch on my iPad from my MacBookAir using Transmit, and I can connect the WFT to my MacBook Air via FTP as well.

Hope you get a chance to look into it. The closest I've gotten is "Other Error", very helpful Canon :-)

Works nicely with the images I uploaded from my MacBook Air, but not very useful at the moment.

thanks,
Daniel,
hermosawave
 
Posts: 1
Joined: Wed Jun 30, 2010 6:20 am

Re: Setting up your connection

Postby TheBrew » Wed Jun 30, 2010 12:03 pm

Yeah... horrible stuff. I've been waiting 2 months for my WFT-E4 now - to be able to see what happens deep down. They keep pushing the delivery date.

I'm trying to figure it out through e-mail with another user - but it's really hard to probe it this way. Once I know more, I'll post info here or a new version of the app that can conform to Canons weirdness. Hang in there..
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4153
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Setting up your connection

Postby technocraft » Wed Jun 30, 2010 7:34 pm

I have a WFT-E2A that I've used successfully to transfer images to an FTP server on my laptop (with an ad-hoc network no less). I'm trying to get it sending to shuttersnitch now, but can't get the ftp working.

I do believe it may be the "creating folders" thing. I couldn't get it working on the laptop until I gave the wft's ftpuser permission to create and delete DIRECTORIES.

If I log into the shuttersnitch ftp server from my computer and attempt to create a directory (with mkdir), it fails: "500 'XMKD' : command not understood". rmdir also fails "500 'XRMD' : command not understood".

HOWEVER, when I get a directory listing from the ssftp server, there's a slew of 00000000 (00000001 - 00000011) directories, presumably created by the wft (timestamp matches what I'm doing right now). So then perhaps it fails at removing the directory?
technocraft
 

Re: Setting up your connection

Postby technocraft » Wed Jun 30, 2010 7:38 pm

According to the diddyftp project page (the ftp server within shuttersnitch):

"I have only added a subset of Ftp Commands. You can upload and download files and list the contents of a folder."

So no create and remove directories? How did the 0000000X directories get there then?
technocraft
 

Re: Setting up your connection

Postby TheBrew » Wed Jun 30, 2010 10:04 pm

Thanks for your input - any thoughts and ideas are welcomed!

I have never had problems creating and deleting directories (the comment from the DiddyFTP project could be an old one?). As far as I remember, the Nikon WTs also do this, and do it without any problems.
But I think you're on to it - I think it's an unsupported command that the WFT is using at some point. Just need to find out which one..

"MKD foldername" / "RMD foldername" works. Do you by any chance have an FTP server log of the WFT logging in, creating a directory structure and/or saving an image? If so, I should be able to see where it fails..

This has top priority, so if you find out anything more, please don't hesitate to share :)
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4153
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Setting up your connection

Postby technocraft » Thu Jul 01, 2010 3:39 pm

From my FileZilla Server:

Creating/Deleting Directory:

(000211) 6/27/2010 18:06:17 PM - (not logged in) (192.168.1.3)> Connected, sending welcome message...
(000211) 6/27/2010 18:06:17 PM - (not logged in) (192.168.1.3)> USER snitch
(000211) 6/27/2010 18:06:17 PM - (not logged in) (192.168.1.3)> 331 Password required for snitch
(000211) 6/27/2010 18:06:17 PM - (not logged in) (192.168.1.3)> PASS *************
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> 230 Logged on
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> TYPE I
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> 200 Type set to I
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> CWD incoming
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> 250 CWD successful. "/incoming" is current directory.
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> PORT 192,168,1,3,212,33
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> 200 Port command successful
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> NLST
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> 150 Opening data channel for directory list.
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> 226 Transfer OK
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> MKD 00000000
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> 257 Directory created successfully
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> RMD 00000000
(000211) 6/27/2010 18:06:17 PM - snitch (192.168.1.3)> 250 Directory deleted successfully
(000211) 6/27/2010 18:06:19 PM - snitch (192.168.1.3)> QUIT
(000211) 6/27/2010 18:06:19 PM - snitch (192.168.1.3)> 221 Goodbye
(000211) 6/27/2010 18:06:19 PM - snitch (192.168.1.3)> disconnected.

Transfer:

(000209) 6/27/2010 18:00:34 PM - (not logged in) (192.168.1.3)> Connected, sending welcome message...
(000209) 6/27/2010 18:00:34 PM - (not logged in) (192.168.1.3)> USER snitch
(000209) 6/27/2010 18:00:34 PM - (not logged in) (192.168.1.3)> 331 Password required for snitch
(000209) 6/27/2010 18:00:34 PM - (not logged in) (192.168.1.3)> PASS *************
(000209) 6/27/2010 18:00:34 PM - snitch (192.168.1.3)> 230 Logged on
(000209) 6/27/2010 18:00:34 PM - snitch (192.168.1.3)> TYPE I
(000209) 6/27/2010 18:00:34 PM - snitch (192.168.1.3)> 200 Type set to I
(000209) 6/27/2010 18:00:34 PM - snitch (192.168.1.3)> CWD incoming
(000209) 6/27/2010 18:00:34 PM - snitch (192.168.1.3)> 250 CWD successful. "/incoming" is current directory.
(000209) 6/27/2010 18:00:34 PM - snitch (192.168.1.3)> PORT 192,168,1,3,219,115
(000209) 6/27/2010 18:00:34 PM - snitch (192.168.1.3)> 200 Port command successful
(000209) 6/27/2010 18:00:34 PM - snitch (192.168.1.3)> STOR TSP_2521.JPG
(000209) 6/27/2010 18:00:34 PM - snitch (192.168.1.3)> 150 Opening data channel for file transfer.
(000209) 6/27/2010 18:00:35 PM - snitch (192.168.1.3)> 226 Transfer OK
(000209) 6/27/2010 18:00:35 PM - snitch (192.168.1.3)> PORT 192,168,1,3,219,116
(000209) 6/27/2010 18:00:35 PM - snitch (192.168.1.3)> 200 Port command successful
(000209) 6/27/2010 18:00:35 PM - snitch (192.168.1.3)> STOR TSP_2522.JPG
(000209) 6/27/2010 18:00:35 PM - snitch (192.168.1.3)> 150 Opening data channel for file transfer.
(000209) 6/27/2010 18:00:36 PM - snitch (192.168.1.3)> 226 Transfer OK
(000209) 6/27/2010 18:00:36 PM - snitch (192.168.1.3)> PORT 192,168,1,3,219,117
(000209) 6/27/2010 18:00:36 PM - snitch (192.168.1.3)> 200 Port command successful
(000209) 6/27/2010 18:00:36 PM - snitch (192.168.1.3)> STOR TSP_2526.JPG
(000209) 6/27/2010 18:00:36 PM - snitch (192.168.1.3)> 150 Opening data channel for file transfer.
(000209) 6/27/2010 18:00:37 PM - snitch (192.168.1.3)> 226 Transfer OK
(000209) 6/27/2010 18:00:37 PM - snitch (192.168.1.3)> PORT 192,168,1,3,219,118
(000209) 6/27/2010 18:00:37 PM - snitch (192.168.1.3)> 200 Port command successful
(000209) 6/27/2010 18:00:37 PM - snitch (192.168.1.3)> STOR TSP_2527.JPG
(000209) 6/27/2010 18:00:37 PM - snitch (192.168.1.3)> 150 Opening data channel for file transfer.
(000209) 6/27/2010 18:00:37 PM - snitch (192.168.1.3)> 226 Transfer OK
(000209) 6/27/2010 18:00:38 PM - snitch (192.168.1.3)> QUIT
(000209) 6/27/2010 18:00:38 PM - snitch (192.168.1.3)> 221 Goodbye
(000209) 6/27/2010 18:00:38 PM - snitch (192.168.1.3)> disconnected.

"/Incoming" is the root directory I had set on the WFT. With shuttersnitch, I left it as "/".
It doesn't do the MKD/RMD every time it connects (maybe only when it comes out of the config menu?).
technocraft
 

Re: Setting up your connection

Postby TheBrew » Thu Jul 01, 2010 4:40 pm

Thanks a bunch! Hope to have a solution ready very soon!

Update: Fix verified (a tiny DiddyFTP bug. 2 bytes..)! This problem will be solved in the version that Apple hopefully approves in a week or so!
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4153
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Setting up your connection

Postby Jonathan » Thu Jul 01, 2010 5:31 pm

Thanks for your persistance Brian,

It's great to see the program working with the WFT-E5D now :)

Now I just need to create some more feature requests... once i've had time to have a good look at the current capabilities.
Time to cross fingers that Apple approves it nice and fast for the rest of the world to get the update.

Great work and thanks again :)

Regards,

Jonathan
Jonathan
 
Posts: 1
Joined: Sat Jun 19, 2010 9:11 am

Re: Setting up your connection

Postby technocraft » Thu Jul 01, 2010 9:43 pm

Awesome. Glad I could help.
technocraft
 

PreviousNext

Return to Canon WFT / EOS 6D/70D/760D/M3/R / PowerShot wi-fi

Who is online

Users browsing this forum: No registered users and 3 guests

cron