WebDAV connection issues

Bugreports = Bugfixes

WebDAV connection issues

Postby TheBrew » Wed Dec 05, 2012 10:51 am

(Edit: Was originally posted in the "Current app approval status" thread)

* Added WebDAV to locations. (only HTTP so far, HTTPS will come in the next version)
* Added WebDAV access to the currently active collection.
* Added a setting to show the network SSID in the status bar.
* You can now sort the filmstrip on rating.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4532
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Version 2.6.2 (Approved)

Postby NEI » Tue Dec 11, 2012 8:03 pm

Great to have WebDAV, but I'm not able to connect to it. I have a collection open on Shuttersnitch, Then I'm using Mac Finder with http://<IP>:8080 and get asked about user/pass. Then I tried everything. Same as FTP, Guest, anonymous. Nothing works... Any hint?
Also tried with Total Commander on Android. Same result -> Cannot connect.
NEI
 
Posts: 11
Joined: Mon Jul 25, 2011 2:30 pm

Re: Version 2.6.2 (Approved)

Postby TheBrew » Tue Dec 11, 2012 8:47 pm

When you try to log in, ShutterSnitch should ask you to put in your super user password to allow WebDAV access.

It'll only do this one time, and it's needed for the authentication check.

If ShutterSnitch doesn't ask, you can "force update" the password info by tapping the wrench-icon and pick "Limited mode". Then enter your super user password. After that, you can exit the limited mode again.

Now try connecting again from your computer. The username will be the same as the one you have for the FTP connection (default: snitch) and the password is your super user password.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4532
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Version 2.6.2 (Approved)

Postby TheBrew » Tue Dec 11, 2012 8:49 pm

Side note, not related to NEI's issue:

Exporting to WebDAV locations in this version is currently only for HTTP connections, not HTTPS. HTTPS will be supported in the next version!
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4532
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Version 2.6.2 (Approved)

Postby NEI » Wed Dec 12, 2012 7:25 pm

Thanks for the tips. But I'm still not able to connect with WebDAV. :-(
NEI
 
Posts: 11
Joined: Mon Jul 25, 2011 2:30 pm

Re: Version 2.6.2 (Approved)

Postby TheBrew » Wed Dec 12, 2012 11:25 pm

Does your super user password contain any special characters?

What if you try changing the WebDAV port in the settings - for example to 12345. In case there's another app running a service on port 8080.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4532
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: Version 2.6.2 (Approved)

Postby NEI » Sat Dec 22, 2012 10:45 pm

Hi again. It's still not working. I have an easy password without special chars. Also tried switching ports. Shuttersnitch also doesn't ask me to enter the super user pass when connecting. And I went to limited mode and back. Nothing works... :-( And I get "UNAUTHORIZED" in Total Commander on Windows. I did now try it with Win7 in a VM also.

Edit: Now also tried to reinstall Shuttersnitch but still no luck with webdav...
NEI
 
Posts: 11
Joined: Mon Jul 25, 2011 2:30 pm

Re: Version 2.6.2 (Approved)

Postby TheBrew » Sat Dec 22, 2012 11:09 pm

(First: you're inside a collection when you're trying this, right?)

What if you, on your Mac open the Finder and press Cmd+K and type in http://TheIPYouSeeWhenEnteringTheCollection:8080 (if port 8080 is the one you have configured in the WebDAV ShutterSnitch settings) and then hit Connect?

The Finder should then ask you for your credentials, pick Registered User and put in "snitch" (if that's the username for the FTP server) and the password is your super user password.

If that doesn't work, I'd say something's funky on your network. Closed ports in your firewall or router or something like that.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4532
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: WebDAV connection issues

Postby NEI » Sun Dec 23, 2012 8:32 am

That's exactly what I do. And I get to the login but no further. In Total Commander I saw an UNAUTHORIZED error message. No idea where I could see finder connection log.
Now to check for lan issues I installed a WebDAV server on my Mac Server (MediaMaster Server) and configured it to use port 8080. To this server I can connect with OS X Finder and Android Total Commander. I have no idea what goes wrong, but something does.

Thx for your time!
NEI
 
Posts: 11
Joined: Mon Jul 25, 2011 2:30 pm

Re: WebDAV connection issues

Postby NEI » Sun Dec 23, 2012 8:58 am

Followup post: Here's a screenshot from a Finder connection attempt. This comes instantly after the "connect" button has been pressed in the login screen. So no timeout... Another problem...
Attachments
Screen Shot 2012-12-23 at 08.55.09.png
Screen Shot 2012-12-23 at 08.55.09.png (41.76 KiB) Viewed 5851 times
NEI
 
Posts: 11
Joined: Mon Jul 25, 2011 2:30 pm

Next

Return to Bugs

Who is online

Users browsing this forum: No registered users and 4 guests

cron