No network connection (Personal hotspot iphone5)

Bugreports = Bugfixes

No network connection (Personal hotspot iphone5)

Postby olemwold » Fri Nov 01, 2013 12:25 pm

I receive the message "No network connection" when I turn on the personal hotspot on my iphone5 (iOs 7.0.3)
When i´m on wifi (Personal hotspot turned off) it functions as normal, but that does´t help me when I'm out and about.

As have not changed any settings since last time i used the app I can't see anything else messing this up. And I have used if quiet a lot after ios7 too, so i don't think that´s the issue. I have tried to do things in different order, (launch the app before/after i turn on the hotspot/camera and vice versa)

This is a problem i just encountered after updating a couple days ago (the update that enabled 64bit processing on A7)

Nikon D4 + WT-5 is what i´m sending from.


Thanks!
olemwold
 
Posts: 18
Joined: Fri Nov 01, 2013 12:10 pm

Re: No network connection (Personal hotspot iphone5)

Postby TheBrew » Fri Nov 01, 2013 12:55 pm

Argh. They changed the interface name again (again, again.. I have to find a more fail-safe way to obtain this info.).

It shouldn't matter in real use though. It'll just report no connection, but things should work and transfer just fine.

If you're using the information at the top to make sure that you've configured the FTP server IP correctly; I can tell you that it's 172.20.10.1 on the iOS 7.0.3 Personal Hotspot.

Thanks a lot for reporting this! Will be fixed in the next version.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4609
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: No network connection (Personal hotspot iphone5)

Postby olemwold » Fri Nov 01, 2013 1:56 pm

Yeah okay.

But my Nikon D4 also reports "FTP error" when trying to connect to snitch. The same error as I have gotten a few times before when the iphone (for some odd reason) sometimes messes up the Data network settings. (So that´s the first thing i checked)

=)
olemwold
 
Posts: 18
Joined: Fri Nov 01, 2013 12:10 pm

Re: No network connection (Personal hotspot iphone5)

Postby TheBrew » Fri Nov 01, 2013 2:11 pm

I have no issues transferring on the 7.0.3 Personal Hotspot. So please try again.

The "No network connection" is nothing but a label telling you something that's wrong because it's confused. It has no bearing on the functionality itself.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4609
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: No network connection (Personal hotspot iphone5)

Postby olemwold » Fri Nov 15, 2013 7:43 pm

Yeah I still cant get it to work. Im starting to get real frustrated now...

Have done a full reset of settings on both the camera and the app. Nothing seems to help.
Attachments
IMG_4100.PNG
I´ve tried the connection wizard a few times. (this is the message I recieve when the hotspot is activated on the iphone, when it´s not the correct IP appears)
IMG_4100.PNG (91.91 KiB) Viewed 6863 times
IMG_4102-2.png
The message I´ve been told has no functionality. However, the app fails to receive when this message appears.
IMG_4102-2.png (607.48 KiB) Viewed 6863 times
IMG_4104-2.jpg
The red circle indicates that I have no problems connecting to the iphone it self.
IMG_4104-2.jpg (319.67 KiB) Viewed 6863 times
olemwold
 
Posts: 18
Joined: Fri Nov 01, 2013 12:10 pm

Re: No network connection (Personal hotspot iphone5)

Postby olemwold » Fri Nov 15, 2013 7:45 pm

One last screengrab, from the connectionwizard.
Attachments
IMG_4099.PNG
And this is at the same time my macbook is connected to the same hotspot with no problems at all. The app seems to have lost its way completely.
IMG_4099.PNG (113.58 KiB) Viewed 6862 times
olemwold
 
Posts: 18
Joined: Fri Nov 01, 2013 12:10 pm

Re: No network connection (Personal hotspot iphone5)

Postby TheBrew » Fri Nov 15, 2013 8:46 pm

Yes, ignore any information shown that the no IP was assigned or connection found. It's not important and purely cosmetic / lack of information to pass on to the user. (And fixed in 3.0.1 to avoid the confusion.)

The issue is somewhere else.

Try going into the ShutterSnitch settings, scroll all the way to the bottom, and turn on "Traffic Inspector".

Then re-enter a collection and try to have your camera send a photo again. See if the traffic inspector gives you a clue as to why the camera doesn't transmit. Feel free to paste the log here too, so I can help you further.
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4609
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: No network connection (Personal hotspot iphone5)

Postby olemwold » Sat Nov 16, 2013 12:06 am

Here's what i get. After this the "FTP error" message appears on the D4.

Thanks for all the help!


Device: iPhone5,2, 32-bit, iOS 7.0.3 (Oles iPhone)
Free memory: 104 255 488
Free disk space: 6 825 742 336
Time: 15. nov. 2013 23:57:11

23:57:11.275 Listening...
23:57:11.284 ShutterSnitch version: 3.0.0
IP: Disconnected
FTP port: 26000
WebDAV port: 8080
Eye-Fi: Disabled (0 cards)
PTP/IP: Disabled
Transcend Wi-Fi card transfers: Disabled
Toshiba FlashAir transfers: Disabled
PQI Air transfers: Disabled
GoPro transfers: Disabled
23:57:11.296 Started WebDAV server on port 8080
23:57:22.587 FTP: Perform USER snitch
23:57:22.590 FTP: Reply 331 Password required for snitch
23:57:22.609 FTP: Perform PASS p*******
23:57:22.610 FTP: Allowed
23:57:22.611 FTP: Reply 230 User snitch logged in.
23:57:22.626 FTP: Perform PWD
23:57:22.627 FTP: Reply 257 "/" is the current directory.
23:57:22.649 FTP: Perform PASV
23:57:22.651 FTP: Reply 227 Entering Passive Mode (172,20,10,1,101,203)
23:57:22.672 FTP: Perform TYPE A
23:57:22.673 FTP: Reply 200 Type set to A.
23:57:22.693 FTP: Perform NLST
23:57:22.774 FTP: Reply 150 Opening ASCII mode data connection for '/bin/ls'.
23:57:41.757 FTP: Reply 226 Transfer complete.
23:57:42.774 FTP: Perform USER snitch
23:57:42.777 FTP: Reply 331 Password required for snitch
23:57:42.798 FTP: Perform PASS p*******
23:57:42.799 FTP: Allowed
23:57:42.800 FTP: Reply 230 User snitch logged in.
23:57:42.830 FTP: Perform PWD
23:57:42.831 FTP: Reply 257 "/" is the current directory.
23:57:42.860 FTP: Perform PASV
23:57:42.862 FTP: Reply 227 Entering Passive Mode (172,20,10,1,102,0)
23:57:42.892 FTP: Perform TYPE A
23:57:42.894 FTP: Reply 200 Type set to A.
23:57:42.918 FTP: Perform NLST
23:57:42.987 FTP: Reply 150 Opening ASCII mode data connection for '/bin/ls'.
23:58:02.769 FTP: Reply 226 Transfer complete.
olemwold
 
Posts: 18
Joined: Fri Nov 01, 2013 12:10 pm

Re: No network connection (Personal hotspot iphone5)

Postby TheBrew » Sat Nov 16, 2013 12:15 am

Oh, the D4.. One would think they'd fix that issue at some point.

Be sure to turn on "Overwrite if same name" under Network -> Options" in the camera settings.

Does that solve it?
Support the development of ShutterSnitch: Rate/review it in iTunes, Tweet about it, make Youtube videos, blog about it.. Get the word out.
TheBrew
The Developer
 
Posts: 4609
Joined: Wed May 05, 2010 8:48 pm
Location: Denmark

Re: No network connection (Personal hotspot iphone5)

Postby olemwold » Sat Nov 16, 2013 12:20 am

That setting seems to have been ON the entire time.. Yeah I don't understand this at all. No one else with this problem?
olemwold
 
Posts: 18
Joined: Fri Nov 01, 2013 12:10 pm

Next

Return to Bugs

Who is online

Users browsing this forum: No registered users and 2 guests